Unable to build

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to build

Ed Anuff
Installed 4.3 and tried to rebuild, getting a ton of "The type or
namespace name 'UIWindow' could not be found.  Are you missing a using
directive or an assembly reference?" errors.   Don't see any update
options, so I think I must be running the latest MonoTouch.

Ed
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
seem to have the same problem.  I was under the impression that these
should work with 4.3, is that not correct?  Is my installation somehow
corrupted?

Ed

On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
> Installed 4.3 and tried to rebuild, getting a ton of "The type or
> namespace name 'UIWindow' could not be found.  Are you missing a using
> directive or an assembly reference?" errors.   Don't see any update
> options, so I think I must be running the latest MonoTouch.
>
> Ed
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

dtavlikos
Check it, because at least 3.2.6 works fine here.

Dimitris Tavlikos

On Mar 21, 2011, at 6:06 AM, Ed Anuff wrote:

> I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
> seem to have the same problem.  I was under the impression that these
> should work with 4.3, is that not correct?  Is my installation somehow
> corrupted?
>
> Ed
>
> On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
>> Installed 4.3 and tried to rebuild, getting a ton of "The type or
>> namespace name 'UIWindow' could not be found.  Are you missing a using
>> directive or an assembly reference?" errors.   Don't see any update
>> options, so I think I must be running the latest MonoTouch.
>>
>> Ed
>>
> _______________________________________________
> MonoTouch mailing list
> [hidden email]
> http://lists.ximian.com/mailman/listinfo/monotouch

_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
Good to know.  Not sure how to go about fixing it.  Wipe
/Developer/MonoTouch and reinstall?

On Sun, Mar 20, 2011 at 11:24 PM, Dimitris Tavlikos <[hidden email]> wrote:

> Check it, because at least 3.2.6 works fine here.
>
> Dimitris Tavlikos
>
> On Mar 21, 2011, at 6:06 AM, Ed Anuff wrote:
>
>> I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
>> seem to have the same problem.  I was under the impression that these
>> should work with 4.3, is that not correct?  Is my installation somehow
>> corrupted?
>>
>> Ed
>>
>> On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
>>> Installed 4.3 and tried to rebuild, getting a ton of "The type or
>>> namespace name 'UIWindow' could not be found.  Are you missing a using
>>> directive or an assembly reference?" errors.   Don't see any update
>>> options, so I think I must be running the latest MonoTouch.
>>>
>>> Ed
>>>
>> _______________________________________________
>> MonoTouch mailing list
>> [hidden email]
>> http://lists.ximian.com/mailman/listinfo/monotouch
>
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
FWIW, when I look at Edit References... in MonoDevelop, it says
version 0.0.0.0 for monotouch.

On Sun, Mar 20, 2011 at 11:30 PM, Ed Anuff <[hidden email]> wrote:

> Good to know.  Not sure how to go about fixing it.  Wipe
> /Developer/MonoTouch and reinstall?
>
> On Sun, Mar 20, 2011 at 11:24 PM, Dimitris Tavlikos <[hidden email]> wrote:
>> Check it, because at least 3.2.6 works fine here.
>>
>> Dimitris Tavlikos
>>
>> On Mar 21, 2011, at 6:06 AM, Ed Anuff wrote:
>>
>>> I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
>>> seem to have the same problem.  I was under the impression that these
>>> should work with 4.3, is that not correct?  Is my installation somehow
>>> corrupted?
>>>
>>> Ed
>>>
>>> On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
>>>> Installed 4.3 and tried to rebuild, getting a ton of "The type or
>>>> namespace name 'UIWindow' could not be found.  Are you missing a using
>>>> directive or an assembly reference?" errors.   Don't see any update
>>>> options, so I think I must be running the latest MonoTouch.
>>>>
>>>> Ed
>>>>
>>> _______________________________________________
>>> MonoTouch mailing list
>>> [hidden email]
>>> http://lists.ximian.com/mailman/listinfo/monotouch
>>
>>
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

dtavlikos
I don't know if deleting /Developer/MonoTouch and re-installing works. But I have installed previous versions back and forth and I did not have any problems. By the way, I just notices that my monotouch lib version in MonoDevelop References also says "0.0.0.0". So I guess this has nothing to do with it.

Is the problem only for the UIWindow class, or are there other UI* classes also?

Dimitris Tavlikos
On Mar 21, 2011, at 8:38 AM, Ed Anuff wrote:

> FWIW, when I look at Edit References... in MonoDevelop, it says
> version 0.0.0.0 for monotouch.
>
> On Sun, Mar 20, 2011 at 11:30 PM, Ed Anuff <[hidden email]> wrote:
>> Good to know.  Not sure how to go about fixing it.  Wipe
>> /Developer/MonoTouch and reinstall?
>>
>> On Sun, Mar 20, 2011 at 11:24 PM, Dimitris Tavlikos <[hidden email]> wrote:
>>> Check it, because at least 3.2.6 works fine here.
>>>
>>> Dimitris Tavlikos
>>>
>>> On Mar 21, 2011, at 6:06 AM, Ed Anuff wrote:
>>>
>>>> I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
>>>> seem to have the same problem.  I was under the impression that these
>>>> should work with 4.3, is that not correct?  Is my installation somehow
>>>> corrupted?
>>>>
>>>> Ed
>>>>
>>>> On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
>>>>> Installed 4.3 and tried to rebuild, getting a ton of "The type or
>>>>> namespace name 'UIWindow' could not be found.  Are you missing a using
>>>>> directive or an assembly reference?" errors.   Don't see any update
>>>>> options, so I think I must be running the latest MonoTouch.
>>>>>
>>>>> Ed
>>>>>
>>>> _______________________________________________
>>>> MonoTouch mailing list
>>>> [hidden email]
>>>> http://lists.ximian.com/mailman/listinfo/monotouch
>>>
>>>
>>

_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
Setting the SDK version in iPhone Build SDK Options to "Default" seems
to resolve the problem.  I was setting it to "4.3" and getting all the
errors.

Thanks

Ed

On Sun, Mar 20, 2011 at 11:45 PM, Dimitris Tavlikos <[hidden email]> wrote:

> I don't know if deleting /Developer/MonoTouch and re-installing works. But I have installed previous versions back and forth and I did not have any problems. By the way, I just notices that my monotouch lib version in MonoDevelop References also says "0.0.0.0". So I guess this has nothing to do with it.
>
> Is the problem only for the UIWindow class, or are there other UI* classes also?
>
> Dimitris Tavlikos
> On Mar 21, 2011, at 8:38 AM, Ed Anuff wrote:
>
>> FWIW, when I look at Edit References... in MonoDevelop, it says
>> version 0.0.0.0 for monotouch.
>>
>> On Sun, Mar 20, 2011 at 11:30 PM, Ed Anuff <[hidden email]> wrote:
>>> Good to know.  Not sure how to go about fixing it.  Wipe
>>> /Developer/MonoTouch and reinstall?
>>>
>>> On Sun, Mar 20, 2011 at 11:24 PM, Dimitris Tavlikos <[hidden email]> wrote:
>>>> Check it, because at least 3.2.6 works fine here.
>>>>
>>>> Dimitris Tavlikos
>>>>
>>>> On Mar 21, 2011, at 6:06 AM, Ed Anuff wrote:
>>>>
>>>>> I've tried with both monotouch-3.99.12 and monotouch-3.2.6 and both
>>>>> seem to have the same problem.  I was under the impression that these
>>>>> should work with 4.3, is that not correct?  Is my installation somehow
>>>>> corrupted?
>>>>>
>>>>> Ed
>>>>>
>>>>> On Sat, Mar 19, 2011 at 6:41 PM, Ed Anuff <[hidden email]> wrote:
>>>>>> Installed 4.3 and tried to rebuild, getting a ton of "The type or
>>>>>> namespace name 'UIWindow' could not be found.  Are you missing a using
>>>>>> directive or an assembly reference?" errors.   Don't see any update
>>>>>> options, so I think I must be running the latest MonoTouch.
>>>>>>
>>>>>> Ed
>>>>>>
>>>>> _______________________________________________
>>>>> MonoTouch mailing list
>>>>> [hidden email]
>>>>> http://lists.ximian.com/mailman/listinfo/monotouch
>>>>
>>>>
>>>
>
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
I'm seeing this problem again with the lastest monotouch-3.99.13 and
MonoDevelop-20402003.  Changing build settings doesn't seem to help.

Ed

On Sun, Mar 20, 2011 at 11:51 PM, Ed Anuff <[hidden email]> wrote:
> Setting the SDK version in iPhone Build SDK Options to "Default" seems
> to resolve the problem.  I was setting it to "4.3" and getting all the
> errors.
>
> Thanks
>
> Ed
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Steve Maier
I saw this too but then right clicked on the uiwindow name and did a resolve to have it add the using statement. It seems that the using is not in there by default.

Steve

Sent from my iPhone

On Mar 24, 2011, at 1:38 AM, Ed Anuff <[hidden email]> wrote:

> I'm seeing this problem again with the lastest monotouch-3.99.13 and
> MonoDevelop-20402003.  Changing build settings doesn't seem to help.
>
> Ed
>
> On Sun, Mar 20, 2011 at 11:51 PM, Ed Anuff <[hidden email]> wrote:
>> Setting the SDK version in iPhone Build SDK Options to "Default" seems
>> to resolve the problem.  I was setting it to "4.3" and getting all the
>> errors.
>>
>> Thanks
>>
>> Ed
>>
> _______________________________________________
> MonoTouch mailing list
> [hidden email]
> http://lists.ximian.com/mailman/listinfo/monotouch
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
Ah, seems to be a problem with the *.xib.designer.cs files.  Your fix
works, except that when these CodeBehind files are updated during
build, the using directive gets removed again.

Ed

On Wed, Mar 23, 2011 at 10:49 PM, Steve Maier <[hidden email]> wrote:

> I saw this too but then right clicked on the uiwindow name and did a resolve to have it add the using statement. It seems that the using is not in there by default.
>
> Steve
>
> Sent from my iPhone
>
> On Mar 24, 2011, at 1:38 AM, Ed Anuff <[hidden email]> wrote:
>
>> I'm seeing this problem again with the lastest monotouch-3.99.13 and
>> MonoDevelop-20402003.  Changing build settings doesn't seem to help.
>>
>> Ed
>>
>> On Sun, Mar 20, 2011 at 11:51 PM, Ed Anuff <[hidden email]> wrote:
>>> Setting the SDK version in iPhone Build SDK Options to "Default" seems
>>> to resolve the problem.  I was setting it to "4.3" and getting all the
>>> errors.
>>>
>>> Thanks
>>>
>>> Ed
>>>
>> _______________________________________________
>> MonoTouch mailing list
>> [hidden email]
>> http://lists.ximian.com/mailman/listinfo/monotouch
>
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Ed Anuff
Well, this is frustrating, since the using directive keeps getting
removed, but if I put it in there and get it to compile through, I
get:

gcc-4.2: error trying to exec
'/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/arm-apple-darwin10-gcc-4.2.1':
execvp: No such file or directory
lipo: can't figure out the architecture type of:
/var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-//cczVs46K.out
Process exited with code 255, command:
/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
-arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
-miphoneos-version-min=4.3 -arch armv6  -std=c99
-I/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/include
-isysroot /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
-c /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.m
-o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
-DDEBUG
/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
-arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
-miphoneos-version-min=4.3 -arch armv6  -isysroot
/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
/var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
-o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/PocketMV
-framework CFNetwork -framework Foundation -framework StoreKit
-framework UIKit -framework AudioToolbox -framework QuartzCore
-framework CoreFoundation -framework CoreGraphics -framework
MediaPlayer -framework iAd -framework AudioToolbox -lz -u _mono_pmip
-u _catch_exception_raise -u _CreateZStream -u _CloseZStream -u _Flush
-u _ReadZStream -u _WriteZStream -liconv -lmono-2.0 -lmonotouch
-L/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/lib
-weak_framework iAd
-L/Users/edanuff/Development/MonoDevelop/Projects/PocketMV/PocketMV
-lopenjpeg -all_load -lstdc++
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

Geoff Norton
This is a bug in beta 1.  Its fixed in the next release.

-g

On 2011-03-24, at 10:56 PM, Ed Anuff wrote:

> Well, this is frustrating, since the using directive keeps getting
> removed, but if I put it in there and get it to compile through, I
> get:
>
> gcc-4.2: error trying to exec
> '/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/arm-apple-darwin10-gcc-4.2.1':
> execvp: No such file or directory
> lipo: can't figure out the architecture type of:
> /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-//cczVs46K.out
> Process exited with code 255, command:
> /Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
> -arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
> -miphoneos-version-min=4.3 -arch armv6  -std=c99
> -I/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/include
> -isysroot /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
> -c /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.m
> -o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
> -DDEBUG
> /Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
> -arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
> -miphoneos-version-min=4.3 -arch armv6  -isysroot
> /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
> /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
> -o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/PocketMV
> -framework CFNetwork -framework Foundation -framework StoreKit
> -framework UIKit -framework AudioToolbox -framework QuartzCore
> -framework CoreFoundation -framework CoreGraphics -framework
> MediaPlayer -framework iAd -framework AudioToolbox -lz -u _mono_pmip
> -u _catch_exception_raise -u _CreateZStream -u _CloseZStream -u _Flush
> -u _ReadZStream -u _WriteZStream -liconv -lmono-2.0 -lmonotouch
> -L/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/lib
> -weak_framework iAd
> -L/Users/edanuff/Development/MonoDevelop/Projects/PocketMV/PocketMV
> -lopenjpeg -all_load -lstdc++
> _______________________________________________
> MonoTouch mailing list
> [hidden email]
> http://lists.ximian.com/mailman/listinfo/monotouch

_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build

dtavlikos
In reply to this post by Ed Anuff
Try disabling the linker and rebuilding. I got the same errors on some projects, even with the latest beta, and it was solved this way.

Dimitris Tavlikos
Software Developer
Email: [hidden email]
Twitter: @dtavlikos
Blog: http://software.tavlikos.com





On Mar 25, 2011, at 4:56 AM, Ed Anuff wrote:

> Well, this is frustrating, since the using directive keeps getting
> removed, but if I put it in there and get it to compile through, I
> get:
>
> gcc-4.2: error trying to exec
> '/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/arm-apple-darwin10-gcc-4.2.1':
> execvp: No such file or directory
> lipo: can't figure out the architecture type of:
> /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-//cczVs46K.out
> Process exited with code 255, command:
> /Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
> -arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
> -miphoneos-version-min=4.3 -arch armv6  -std=c99
> -I/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/include
> -isysroot /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
> -c /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.m
> -o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
> -DDEBUG
> /Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin/gcc-4.2
> -arch i386 -gdwarf-2 -fobjc-legacy-dispatch -fobjc-abi-version=2
> -miphoneos-version-min=4.3 -arch armv6  -isysroot
> /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk
> /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/main.6.o
> -o /var/folders/bN/bNNyovynEUaeui1jOJWV5U+++TI/-Tmp-/tmp7346e993.tmp/PocketMV
> -framework CFNetwork -framework Foundation -framework StoreKit
> -framework UIKit -framework AudioToolbox -framework QuartzCore
> -framework CoreFoundation -framework CoreGraphics -framework
> MediaPlayer -framework iAd -framework AudioToolbox -lz -u _mono_pmip
> -u _catch_exception_raise -u _CreateZStream -u _CloseZStream -u _Flush
> -u _ReadZStream -u _WriteZStream -liconv -lmono-2.0 -lmonotouch
> -L/Developer/MonoTouch/SDKs/MonoTouch.iphonesimulator.sdk/usr/lib
> -weak_framework iAd
> -L/Users/edanuff/Development/MonoDevelop/Projects/PocketMV/PocketMV
> -lopenjpeg -all_load -lstdc++
> _______________________________________________
> MonoTouch mailing list
> [hidden email]
> http://lists.ximian.com/mailman/listinfo/monotouch

_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch