Failed to load AOT module ... in aot-only mode

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to load AOT module ... in aot-only mode

dermotos
I've added a new class library to my project, but now it wont run. During startup, I receive the below error:

Failed to load AOT module '/private/var/mobile/Applications/E7CCBC79-0454-4086-8B52-2056A27C50D9/Apollo.app/networkio.dll.dylib' in aot-only mode.

How can I fix this? I cannot find anything on google.
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load AOT module ... in aot-only mode

Rolf Bjarne Kvinge
Hi,

dylibs aren't allowed on iOS devices, so this is somewhat strange. Can you add "-v -v -v" to the additional mtouch arguments and attach the complete build log (after doing a clean)?

Rolf

On Wed, May 2, 2012 at 10:23 AM, dermotos <[hidden email]> wrote:
I've added a new class library to my project, but now it wont run. During
startup, I receive the below error:

Failed to load AOT module
'/private/var/mobile/Applications/E7CCBC79-0454-4086-8B52-2056A27C50D9/Apollo.app/networkio.dll.dylib'
in aot-only mode.

How can I fix this? I cannot find anything on google.

--
View this message in context: http://monotouch.2284126.n4.nabble.com/Failed-to-load-AOT-module-in-aot-only-mode-tp4602614.html
Sent from the MonoTouch mailing list archive at Nabble.com.
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch


_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch
Reply | Threaded
Open this post in threaded view
|

Re: Failed to load AOT module ... in aot-only mode

dermotos
I had to delete the app from the device and re upload to fix it. Had to do it on all 3 of my test devices. It seems uploading to the device doesn't over write something it should, which was causing the problem. 

If it helps bug finding, the dll it was looking for was the assembly name of an old class library I removed while refactoring. (there was definitely no references left in the project to the old dll)

Sent from mobile device. Please excuse brevity & errors. 

On 02/05/2012, at 8:47 PM, Rolf Bjarne Kvinge <[hidden email]> wrote:

Hi,

dylibs aren't allowed on iOS devices, so this is somewhat strange. Can you add "-v -v -v" to the additional mtouch arguments and attach the complete build log (after doing a clean)?

Rolf

On Wed, May 2, 2012 at 10:23 AM, dermotos <[hidden email]> wrote:
I've added a new class library to my project, but now it wont run. During
startup, I receive the below error:

Failed to load AOT module
'/private/var/mobile/Applications/E7CCBC79-0454-4086-8B52-2056A27C50D9/Apollo.app/networkio.dll.dylib'
in aot-only mode.

How can I fix this? I cannot find anything on google.

--
View this message in context: http://monotouch.2284126.n4.nabble.com/Failed-to-load-AOT-module-in-aot-only-mode-tp4602614.html
Sent from the MonoTouch mailing list archive at Nabble.com.
_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch


_______________________________________________
MonoTouch mailing list
[hidden email]
http://lists.ximian.com/mailman/listinfo/monotouch